Global - Internet Instability

Incident Report for Teraswitch

Identified

Teraswitch is currently working on mitigations related to this issue, although traffic issues have settled.

At this time, it appears a bulk of the high-capacity US to EU cables had a fault around the same time. Our NY to London path, which had been cut and resolved earlier today, went down again, and our Ashburn to Frankfurt path suffered an outage around the same time.

At this time, the network has stabilized and we are working to ensure any additional events are not as impactful to traffic.
Posted Jul 29, 2026 - 19:35 UTC

Investigating

Teraswitch is looking into general Internet Instability.
Posted Jul 29, 2026 - 19:15 UTC
This incident affects: Global Network Services (Intra-Market Connectivity, Internet Exchanges and Peering).