SGP2 - Internet Connectivity Loss

Incident Report for Teraswitch

Resolved

Our facility partner has restored power to Teraswitch's SGP2 network racks.

Root cause: both redundant PDUs in each network rack were fed by power breakout boxes connected to the same overhead electrical bus bar, creating a single point of failure. Facility engineers relocated one breakout box to the correct bus, restoring power to the network equipment and eliminating the single point of failure.

We expect no further impact at this time. Customer systems did not lose power at any point during this event.
Posted Jul 18, 2026 - 01:57 UTC

Identified

Teraswitch has isolated this incident to a vendor power maintenance event with unexpected impact, affecting both of our network racks and causing an Internet connectivity loss at SGP2. Customer services are believed to be powered on without upstream connectivity. Facility staff are at work to restore Internet connectivity and bring the site back online. We will provide an update as soon as possible.
Posted Jul 18, 2026 - 00:22 UTC

Investigating

Teraswitch is investigating reports of Internet connectivity loss at SGP2. We will provide an update shortly.
Posted Jul 17, 2026 - 23:45 UTC
This incident affected: SGP2 - Singapore.