New York <-> London Detoured

Incident Report for Teraswitch

Resolved

This detour has already cleared and was a momentary disruption. TeraSwitch will engage our transport vendor for a better understanding of this incident.
Posted Oct 29, 2025 - 00:36 UTC

Investigating

Our trans-Atlantic link from London to New York has dropped offline.

Traffic is diverted via Ashburn to Frankfurt.
Posted Oct 29, 2025 - 00:20 UTC
This incident affected: Global Network Services (Intra-Market Connectivity).