Internet Connectivity Instability

Incident Report for Teraswitch

Resolved

This incident is now considered resolved.
Posted Nov 17, 2025 - 13:45 UTC

Identified

We are observing further Internet connectivity instability due to the attack and are continuing to apply mitigations. We will continue to monitor the situation until resolution and update on any further changes.
Posted Nov 15, 2025 - 13:29 UTC

Monitoring

Teraswitch was attacked by a DDOS attack that specifically targeted our infrastructure and blockchain services. While our network has the capacity and mitigation ability, it took longer than expected to identify good traffic from attack traffic without further causing worse issues.

Some attack traffic sources came from very abnormal and specific locations, such as AT&T (US ISP) and a group of Brazilian ISPs. This traffic primarily landed in our Dallas data center, which overloaded select network links there on its way towards the attack targets.

We have tightened our rule sets, shifted traffic around, and are working to ensure impacts are continually mitigated.
Posted Nov 14, 2025 - 17:25 UTC

Investigating

Teraswitch is investigating moments of Internet connectivity instability.
Posted Nov 14, 2025 - 15:17 UTC
This incident affected: Global Network Services (Intra-Market Connectivity, Global External Internet, Internet Exchanges and Peering).