Backbone - Seattle to Tokyo Detour

Incident Report for Teraswitch

Resolved

Tokyo to Seattle has been nominal operation for many hours now. We are working with our vendors to understand the issue, but at this time we consider the incident and impact resolved.
Posted Jun 04, 2026 - 21:11 UTC

Identified

Teraswitch has identified a loss of two undersea cables landing in our SEA1 location from Tokyo. This is likely a terrestrial issue inside Seattle.

Traffic was automatically diverted to our LA to Tokyo path.
Posted Jun 04, 2026 - 15:27 UTC
This incident affected: Global Network Services (Intra-Market Connectivity, Ultra-Low Latency Connectivity).