Seattle -> Tokyo Cable Fault

Incident Report for Teraswitch

Resolved

Fault has cleared and cable returned to service.
Posted Nov 29, 2025 - 13:02 UTC

Monitoring

Terawitch Network Operations has observed a subsea cable fault between our Seattle and Tokyo POPs. Latency to Tokyo may be increased while the system is down. We have reached out to our cable provider for an update.
Posted Nov 29, 2025 - 05:21 UTC
This incident affected: Global Network Services (Intra-Market Connectivity) and TYO1 - Tokyo, Japan, TYO2 - Tokyo, Japan.