SGP1 - Internet Traffic Latency

Incident Report for Teraswitch

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 18:30 UTC

Identified

Teraswitch is rerouting traffic due to high latency seen with multiple internet providers in Singapore.
Posted Aug 26, 2025 - 14:22 UTC
This incident affected: SGP1 - Singapore.