PIT1 - Sporadic Internet Connectivity Issues

Incident Report for Teraswitch

Monitoring

Reload is complete and the network operation appears to have returned to normal.

We will follow up this notification with a RCA and repair plan.
Posted Mar 17, 2026 - 20:43 UTC

Identified

We have located a network device with software issues, our team is about to reload the device.

This issue affects mostly colocation customers at PIT1, but traffic from various sources may have passed through this device depending on the direction of network flow.
Posted Mar 17, 2026 - 20:36 UTC

Investigating

Teraswitch is investigating reports of select markets having issues connecting to PIT1.
Posted Mar 17, 2026 - 20:05 UTC
This incident affects: PIT1 - Pittsburgh, PA.