New York <-> London Detoured

Incident Report for Teraswitch

Resolved

The subsea cable repair is done, the connections have been stable for nearly 24 hours, and traffic has been normalized across the link.

This concludes this event.
Posted Aug 20, 2025 - 18:11 UTC

Monitoring

Our sub-sea cable provider is estimating an August 20th restoration of service.

Traffic remains detoured at this time.
Posted Aug 13, 2025 - 16:50 UTC

Identified

Teraswitch has detected the loss of our subsea capacity from EWR1 to LON1.

All traffic has been diverted over other paths, but higher latency is expected over the longer path.
Posted Aug 12, 2025 - 20:19 UTC
This incident affected: Global Network Services (Intra-Market Connectivity) and EWR1 - Newark, NJ, EWR2 - Newark, NJ, LON1 - London, United Kingdom.