Singapore <-> Tokyo Detoured

Incident Report for Teraswitch

Resolved

An alternative undersea cable has been established to restore this route.

SGPTYO connectivity is now via backbone.
Posted Jan 26, 2026 - 13:57 UTC

Update

We received an update from our vendor that this will be repaired prior to Jan 31st. We have also purchased another diverse path to be installed in Jan 2026 to prevent the increased latency in the future.
Posted Dec 23, 2025 - 16:01 UTC

Monitoring

Due to a sub-sea cable fault, our transport provider estimates an 10/17/2025 restoration to capacity between SGP1/2 to our backbone via Tokyo.
Posted Sep 26, 2025 - 00:00 UTC
This incident affected: Global Network Services (Intra-Market Connectivity) and SGP1 - Singapore, SGP2 - Singapore.