AMS1 - Loss of Connectivity

Incident Report for Teraswitch

Monitoring

We have implemented a temporary fix and AMS1 connectivity is now restored. We will follow up with a permanent fix and RCA.
Posted Mar 27, 2026 - 00:14 UTC

Update

We are working on a resolution to a multiple diverse fiber cut that is impacting AMS1 connectivity.

The issue has been identified by the fiber vendor, and we are working on an alternative fiber solution to restore connectivity.
Posted Mar 26, 2026 - 22:53 UTC

Identified

Teraswitch is working to resolve a simultaneous backbone fiber cut affecting AMS1 connectivity.
Posted Mar 26, 2026 - 22:08 UTC
This incident affects: AMS1 - Amsterdam, Netherlands.